ITEC2110:Fall2011:Fuller:Projects:Project3:BlenderTips

From GGCWiki
Jump to: navigation, search

Contents

The Basics

Getting Started

  • Make sure that you are using Blender version 2.59
  • Blender has lots of functions that you do not need to understand. Do not let yourself get overwhelmed. Just focus on the few controls that matter for what you need to accomplish.
  • Be sure to set up your mouse for using 3 buttons. If you do not have a mouse that supports 3 buttons, go to File => User Preferences => Input to set up the controls to work without it. The important ones for controlling the view are under "View2D" and "View2D Buttons List".

Basic Interaction

  • LEFT MOUSE BUTTON => Click buttons, interact with handles, accept a manipulation, place the crosshair (location where objects will be added)
  • RIGHT MOUSE BUTTON => Select objects/vertices, cancel a manipulation
  • SHIFT + RIGHT MOUSE BUTTON => Select another object in addition to the first

Controlling the View

  • MIDDLE MOUSE BUTTON => Rotate view
  • CTRL + MIDDLE MOUSE BUTTON => Zoom view
  • SHIFT + MIDDLE MOUSE BUTTON => Shift view
  • View Button => Choose view
  • Numpad keys => Preset views

Managing Panes

  • To split a pane, click and drag on corner with the 3 diagonal lines (the cursor should look like a crosshair)
  • If you accidentally create too many panes, click on the same corner and drag a pane into another one. An arrow should appear showing that the pane you are dragging will override the pane you are dragging into.
  • Click and drag the edges to resize a pane.
  • There is a pop-out menu in the lower left-hand corner of each pane that changes the content of a pane. It has an icon next to an up and down arrow.
  • Useful panes: 3D View, Outliner, Properties, Timeline, DopeSheet
  • If part of one of your panes seems to disappear, try clicking on one of the small circles with a plus on the inside.

Content Creation and Manipuation

Adding Content

  • At the top of the screen is a button that says "Add"
  • Add => Mesh to add objects (Cube, Cyllinder, UV Sphere, Plane, etc.)
  • Add => Lamp to add lights. Useful lights are Point and Spotlight.
  • Objects are added wherever the crosshair is (reposition with the left mouse button).

Editing Objects

  • Select objects with the right mouse button
  • Select objects in object mode / Select vertices in edit mode
  • Edit mode/object mode selected at bottom of 3D View Pane (Says "Object Mode" or "Edit Mode" with up and down arrows and a pop-out menu)

Manipulating Objects in Object Mode

  • Move along x/y/z axis with red/green/blue handles
  • G (grab) => Free move => click to accept
  • S (scale) => drag mouse => click to accept
  • R (rotate) => drag mouse => click to accept *only in 2 dimensions, so change view
  • SHIFT + D => duplicate object
  • CTRL + Z => undo a change
  • CTRL + SHIFT + Z => redo a change

Manipulating Objects in Edit Mode

  • A (all) => Select or deselect all vertices
  • B (block grab) => Select a region of vertices

Coloring an Object

  • Properties Pane (on the right) => Material tab (circle icon)
  • => + new
  • Diffuse => Click on the color => Choose a new color

Adding a Texture

  • Properties Pane => Texture tab (checkerboard icon)
  • => + New
  • Type drop-down box
  • Scroll down to Influence => Change color
  • OR for image: Type => Image or Movie => Open => Choose File
  • When dealing with images, be sure to adjust the image mapping. Image Mapping => Extension => Repeat to tile, Extend to stretch the image, or Clip to keep the image the same size (but not necessarily cover the entire object)
  • When adding a texture, make sure that the object has a material first (Properties Pane => Material tab (circle icon) => + new)

Parenting Objects

  • Be sure you are in Object Mode
  • Select the object that will be the child
  • Shift-select the object that will be the parent
  • On the bottom bar of the 3D View pane, Object => Parent (or just press CTRL+P)
  • If you check the Outliner pane, you will notice that the child object is listed within the parent object (click the plus next to the object name to expand it)

Boolean (difference, union, intersection)

  • Properties Pane (on right) => Modifiers tab (wrench icon)
  • Add Modifier => Boolean => Choose Type => (Choose Second Object) => Apply

Rendering and Animation

Rendering An Image

  • Based on whatever is within view of the camera
  • Properties Pane => Render tab (camera icon)
  • Be sure to change the resolution to something smaller (say, 400x300 px)
  • Render => Image
  • F11 => show/hide render
  • ESC => hide image
  • F3 => Save rendered image(Or on bar below the image click Image => Save as Image)

Animation

  • Animation is acomplished by creating keyframes. Keyframes define a significant change in an image and Blender will fill in the rest. For instance, if an object is in location A for keyframe 1 and location B for keyframe 2, Blender will animate the object as moving from location A to location B. This can also be done for rotation and scaling.
  • In the 3D View Pane => press i to set a keyframe => Choose the type of keyframe (location, rotation, scaling)

Action Editor/Dope Sheet/Timeline

- For animation, some useful panes are the Action Editor, the Dope Sheet, and the Timeline - The Dope Sheet displays keyframes for all objects at once - The action editior displays the keyframes for a selected object - Keyframes appear as diamonds - The timeline has playback controls and allows you to set the number of frames

Keyframe Manipulations

  • Right-click to select a keyframe
  • Press G or Right-click to drag and move keyframes (press the left mouse button to confirm the movement)
  • x => delete a key frame

Render Animation

  • Properties Pane => Render tab => Animation
  • Dimensions => Set up the Frame Rate and the number of frames (Frame Range)
  • Output => Set up the export directory
  • Output => AVI Codec to export an AVI file
  • Render => Animation. This process will probably take a while. If you need to cancel it, click the X next to the progress bar at the top of the screen.
Personal tools